Skocz do zawartości

A- A A+
A A A A
Zdjęcie

Błąd aktualizacji


  • Zaloguj się, aby dodać odpowiedź
7 odpowiedzi w tym temacie

#1 Aribeth

Aribeth

    Mruk

  • Użytkownik
  • PipPipPipPip
  • 116 postów

Napisano 06 grudzień 2018 - 11:19

Podczas aktualizacji wyrzuca następujący błąd:

python3: installed python3 package post-installation script subprocess
returned error exit status 4

W rezultacie nic się nie aktualizuje. Kiedy próbowałam reinstalacji, pokazał się ten sam błąd, a kiedy próbowałam odinstalować python3 żeby go później zainstalować, system zaczął krzyczeć że to grozi uszkodzeniem.
System to Mint Mate, komputer to Acer Aspire.
  • 0

#2 Dejv84

Dejv84

    Statysta

  • Użytkownik
  • PipPip
  • 9 postów
  • Skąd:Kraków

Napisano 06 grudzień 2018 - 11:24

Polecam Ci pobranie bibliotek z Linux Mint -17.2 lub jeśli używasz dużego softa to  Linux Mint xfce. Sam polecam Cinamona.


  • -2

#3 Aribeth

Aribeth

    Mruk

  • Użytkownik
  • PipPipPipPip
  • 116 postów

Napisano 06 grudzień 2018 - 13:12

A to nie namiesza mi w systemie? Bo ja mam wersję 19.
  • 0

#4 marder

marder

    evil admin

  • Administrator
  • 2769 postów
  • Skąd:/home/marder

Napisano 06 grudzień 2018 - 18:49

Oczywiście że namiesza. Downgrade bibliotek systemowych to jedna z najgłupszych rzeczy jakie może zrobić użytkownik Linuksa.

Przejdźmy teraz do Twojego problemu. Przypuszczam że ten komunikat jest powodowany przez jakiś problem z zależnościami. W przypadku programów pobieranych z repozytorium Minta, te problemy nie występują, zakładam więc że "sprawcą" jest coś co zostało zainstalowane spoza oficjalnego repozytorium.

Czy instalowałaś ostatnio coś z paczek *deb, albo plików *run lub *tar.bz2?


  • 0

Nierozwiązywalność jest zawsze stanem przejściowym. 


#5 Aribeth

Aribeth

    Mruk

  • Użytkownik
  • PipPipPipPip
  • 116 postów

Napisano 07 grudzień 2018 - 13:32

Tak, na laptopie instalowany był hplip pobrany ze strony twórców. Wersja hplip będąca w repozytorium nie chciała obsługiwać drukarki którą kupiłam, potrzebna była najnowsza wersja.
Tylko czy jeśli będzie trzeba usunąć hplip czy drukarka przestanie działać? Jak rozwiązać tę sytuację?
  • 0

#6 marder

marder

    evil admin

  • Administrator
  • 2769 postów
  • Skąd:/home/marder

Napisano 07 grudzień 2018 - 21:52

No to już wiemy w czym tkwi problem.

Teraz czas się za to zabrać. Uruchom terminal, potem po kolei wykonuj komendy:

cd /usr/share/python3/runtime.d
sudo mv hplip-data.rtupdate /home/TWOJA_NAZWA

Gdzie Twoja_nazwa to Twoja nazwa użytkownika. Przed wykonaniem działania system poprosi Cię o hasło.

 

Po wykonaniu tych dwóch komend, zaktualizuj system, a potem sprawdź, czy hplip działa.

Jeżeli nie, daj znać, napiszę jak to odwrócić.


  • 1

Nierozwiązywalność jest zawsze stanem przejściowym. 


#7 Aribeth

Aribeth

    Mruk

  • Użytkownik
  • PipPipPipPip
  • 116 postów

Napisano 08 grudzień 2018 - 21:07

Dziękuję Marder, aktualizacja się powiodła, drukarka też działa. Ta komenda przeniosła jeden plik do mojego folderu domowego. Czy teraz go usunąć?
  • 0

#8 kuba

kuba

    Narrator

  • Super Moderator
  • 1535 postów

Napisano wczoraj, 00:12

Może się jeszcze przydać; w przypadku problemów będziesz miała skąd go przywrócić. Lepiej nie usuwaj.


  • 1


Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych