Skocz do zawartości

A- A A+
A A A A
Zdjęcie

Problem z HPLIP

HP HPLIP Linux drukarka

  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Melchior

Melchior

    Milczek

  • Użytkownik
  • PipPipPip
  • 43 postów

Napisano 03 październik 2015 - 15:38

Przestała działać drukarka. Okazało się że w HPLIP brakuje sterownika. Kiedy klikam na "Install required plugin", podaję hasło administratora, a następnie wybieram opcję pobierania pluginu z serwerów HP. Niestety podczas instalacji wyskakuje komunikat:

hplip-3.15.2-plugin.run file does not match its checksum. File may have been corrupted or altered 

Raz, drugi i trzeci. Co jeszcze mogę zrobić żeby to zainstalować i uruchomić drukarkę? System to Mint 17.2, drukarka to HP LaserJet 1018.


  • 0
Armata: narzędzie stosowane do poprawiania granic państwowych.
Ambrose Bierce

#2 Gość_kuba_*

Gość_kuba_*
  • Gość

Napisano 03 październik 2015 - 15:59

A próbowałeś najpierw pobrać na dysk a dopiero potem instalować?


  • 1

#3 Melchior

Melchior

    Milczek

  • Użytkownik
  • PipPipPip
  • 43 postów

Napisano 03 październik 2015 - 16:33

Też na to wpadłem. Wujek Google po wpisaniu frazy "drivers download hp laserjet 1018" kieruje mnie na stronę na serwerze HP która TEORETYCZNIE ma służyć do pobierania sterowników. Niestety sterowników tam nie ma. Są jakieś trywialne samouczki wideo, jest opis rozwiązywania kilku równie trywialnych problemów, ale sterowników i to dla Linuksa a nie Jedynie Słusznego Systemu, nie ma.
Poza tym, skoro sterownik pobierany z serwera HP jest identyfikowany jako uszkodzony lub podmieniony, to czy uda się go zainstalować z dysku? Przecież wtedy HPLIP też będzie się pluł że mu suma kontrolna pliku nie pasuje...

Użytkownik Melchior edytował ten post 03 październik 2015 - 16:33

  • 0
Armata: narzędzie stosowane do poprawiania granic państwowych.
Ambrose Bierce

#4 marder

marder

    evil admin

  • Administrator
  • 3340 postów
  • Skąd:/home/marder

Napisano 03 październik 2015 - 18:58

Wejdź tutaj: https://www.openprin...les/HP/plugins/

Pobierz dwa pliki:

hplip-tutaj numer twojej wersji -plugin.run

hplip-tutaj numer twojej wersji -plugin.run.asc

 

Zapisz je w tym samym folderze. Następnie podczas instalacji pluginu, wybierz instalację nie z serwera ale z pliku i podaj ścieżkę do pliku .run (nie run.asc!).

 

P.S. Powodem problemu jest bug w samym hplip, bug raportowany już w kwietniu, na bugs.launchpad.net.


  • 0

Nierozwiązywalność jest zawsze stanem przejściowym. 

 

Ziewanie, to cichy krzyk o kawę.


#5 Melchior

Melchior

    Milczek

  • Użytkownik
  • PipPipPip
  • 43 postów

Napisano 13 październik 2015 - 06:09

Dzięki, pomogło.
  • 0
Armata: narzędzie stosowane do poprawiania granic państwowych.
Ambrose Bierce



Również z jednym lub większą ilością słów kluczowych: HP, HPLIP, Linux, drukarka

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych